SLIP Imagery Services | WA Now Degraded Performance

Incident Report for Data.wa.gov.au

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 16:23 AWST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2026 - 15:56 AWST

Investigating

The WA Now Imagery service is currently displaying a lower resolution satellite image over parts of the Cocos and Christmas Islands.

A resolve will be implemented and communicated soon.
Posted Jun 08, 2026 - 09:03 AWST
This incident affected: SLIP Data Services (APIs) (Landgate Subscription Imagery Services).